Forum

You need to log in to create posts and topics.

Getting Bossa Loader working in OSX

Hi all,

I recently bought a Kaiwa kit from Thonk and assembled it, got it working and am enjoying using it.

The process was not very straightforward however so I thought I share how I succeeded here in the hope others may find it useful.

 

When it came trying to getting the firmware uploaded I ran into an issue. I successfully downloaded the Bossa Loader for OSX (I'm on 10.12.6 Sierra) and the firmware.bin file. Powered up the module, connected it via USB to my Mac. Ran the command:

ls /dev/tty.* 

in the Terminal to discover the name of the module's interface (USBMODEM1411). Restarted Bossa Loader as it seems it has to be run AFTER the module is booted and connected. Selected the correct interface from the drop down menu (avoiding the one that also says USBMODEM1411, but doesn't have TTY in it) and browsed for the firmware - hit upload - error. Something about "java.io exception cannot run program bossac"

Long story short, I could not make it work by mounting the disk image and running the Bossa app from there. I had to copy the whole folder (not just the app) to /Applications AND (this is the important bit) remove the extended 'quarantine' permissions that the Mac had given it due to it being from an unknown developer. This is done using the following line in Terminal:

sudo xattr -dr com.apple.quarantine /Applications/BossaLoader/

and then type in your password.

Then and only then would it upload the firmware! Once I worked that out everything else was pretty straightforward - although the Calibration routine took longer than I expected and I thought maybe it had got stuck - but my patience was rewarded.

I hope this info helps someone else to enjoy making and using the Kaiwa module, as its great fun!

best regards from sunny Australia
:L
http://snarl.org